Troubleshooting WiFree

Open DIY Projects Stuhlkreis WiFree Copter Troubleshooting WiFree

Dieses Thema enthält 165 Antworten und 39 Teilnehmer. Es wurde zuletzt aktualisiert von Avatar 1907 vor 8 Monate, 3 Wochen.

Ansicht von 15 Beiträgen - 16 bis 30 (von insgesamt 166)
  • Autor
    Beiträge
  • #3309
    bender2004
    bender2004
    Teilnehmer

    Hallo,
    der WL0084E funktioniert bei mir auch nicht. Ich hatte am Wochenende ausdrücklich einen WL0084B bestellt, was haben die mir geschickt: den WL0084E. Der geht wieder zurück.
    Gibt es vielleicht eine Liste mit funktionierenden WLAN-Adaptern? Oder hat jemand einen anderen Adapter, der funktioniert, im Einsatz?
    Viele Grüße
    Jörg

    #3310
    Avatar
    doing
    Teilnehmer

    Hallo,

    der Edimax EW-7811Un geht auf jeden Fall nicht, das hatte ich im ‚App‘ Thread berichtet. Der LogiLink WL0084B hingegen funktioniert auf Anhieb. Es wäre aber wirklich schön, wenn man nicht auf diesen einen LogiLink WiFi Dongle angewiesen wäre. Ich würde gerne einen Edimax EW-7612UAn V2 einsetzen, weil ich mir von dem eine deutlich bessere Reichweite verspreche.

    Leider sind auch die Zugangsdaten zum Login auf einem Pi mit dem WiFree Image nicht bekannt. So wird es schwer, wenn man selbst mal einen Versuch machen will das Ganze mit einem anderen WiFi Dongle zu konfigurieren…

    #3312
    EagleEi
    EagleEi
    Keymaster

    Hallo Zusammen,
    Ich habe von unserem Programmierer folgende Infos erhalten:

    die Standardzugangsdaten pi/raspberry müssten eigentlich
    funktionieren, ansonsten auch root/wifree (user/passwort).

    Es wird ein WLAN-Adapter benötigt, dessen Chipsatz von hostapd
    unterstützt wird. Infos zu einigen Adaptern bezüglich
    (nicht-)Unterstützung finden sich z.B. hier:
    http://elinux.org/RPi_USB_Wi-Fi_Adapters Oft wird im Verkaufstext der
    verwendente Chipsatz nicht angegeben, da hilft nur googlen oder
    testen.

    Konkret der Edimax EW-7811Un wird nur von einer speziellen
    hostapd-Version unterstützt, nähere Infos z.B. hier:
    https://itwelt.org/anleitungen-howto/raspberry-pi/590-raspberry-pi-und-edimax-ew-7811un-access-point-einrichten

    #3315
    Avatar
    doing
    Teilnehmer

    Hallo EagleEi,

    ich hatte den Pi Zero mit Tastatur versehen und einen Monitor angeschlossen. Dort habe ich natürlich die Standard Zugangsdaten pi/raspberry versucht um mich anzumelden, was nicht ging – daher meine Frage.
    Es wird dann wohl root/wifree sein…

    Zum Thema hostapd gibt es drüben im Raspberry Forum einen aktuellen Thread der genau das Gegenteil besagt. Man soll eben KEINE angepasste hostapd Version nutzen sondern die Originale aus dem aktuellen Raspbian Jessie Image von Mai 2016.

    Vielleicht gibst du Letzteres mal an deinen Programmierer weiter und wir haben dann bald ein universelles Image das mit verschiedenen WiFi Dongles funktioniert.

    Grüsse
    Sebastian

    #3318
    Avatar
    doing
    Teilnehmer

    Hallo,

    ich habe meinen WiFree Copter nun fertig 🙂

    An den PC angeschlossen kann ich die Motoren über INAV laufen lassen. Bis hierhin funktioniert alles.

    Wenn ich aber versuche die Motoren über die App zu starten passiert leider nichts. Ich kann sie über die App scharf schalten, kann die Cam aktivieren, kann Videos aufnehmen etc. Nur eben die Motoren laufen nicht los.

    Hat einer eine Idee woran das liegen kann?

    Grüsse
    Sebastian

    #3319
    Michel76
    Michel76
    Teilnehmer

    Was benutzt für ein FC-board?
    evtl. hast du in den einstellungen „always disarmed“ drin stehen, dann sagt die app zwar scharf schalten, aber das board ignoriert das…
    das wäre jetzt mein erster anlaufpunkt.

    #3320
    Avatar
    doing
    Teilnehmer

    Hallo Michel76,

    ich nutze das CC3D Board. Aber das ‚Problem‘ hat sich eben gelöst… wenn man den Flexi Port mit dem Main Port verwechselt kann das nicht gehen… gerade umgesteckt und alles ist fein. Jetzt muss nur noch das Wetter passen 🙂

    Grüsse
    Sebastian

    #3321
    Avatar
    doing
    Teilnehmer

    Hallo,

    gleich noch ne Frage 😉

    Muss ich das Ganze jetzt noch auf meinen WiFree Copter kalibrieren?

    Mir ist aufgefallen, dass (gerade im unteren Drehzahlbereich) die vorderen Motoren auch mal komplett stehen bleiben. Das kann ja nicht gesund sein für den Copter…

    Grüsse
    Sebastian

    #3322
    Michel76
    Michel76
    Teilnehmer

    wenn du für das cc3D board Librepilot verwendest, sollte durch die „setupfunktion“ in der software das problem behoben werden können. Probeller natürlich vorher demontieren, bitte.

    #3323
    Avatar
    doing
    Teilnehmer

    Hallo Michel76,

    im Moment verwende ich das zum WiFree Copter empfohlene INAV. Die Settings aus der WiFree-INAV_7.17.2016.12.24.txt habe ich entsprechend geladen. Steuere ich die Motoren über INAV an, dann habe ich das Problem nicht. Bei ~1160 fangen alle vier Motoren gleichmäßig an zu drehen und reagieren auch gleichmäßig auf Schubwechsel. Steuere ich die Motoren hingegen über die WiFree App an, dann tritt das beschriebene Verhalten auf.

    Grüsse
    Sebastian

    #3324
    Michel76
    Michel76
    Teilnehmer

    ich denke mal, das da cleanflight als konfigurationssoftware verwendet wird, um das board einzustellen? wenn ja, Links im reiter Configuration kann man rechts esc/motor features den startpunkt der motoren einstellen. in deinem fall würde ich, wie auf meinem Bild 1150 min. eingeben. dann sollte das eigentlich gehen.

    edit:

    bei cc3D boards bin ich eher von Librepilot ausgegangen, da das die gängige software für diese boards is. habe aber dabei vergessen, das man diese boards auch mit cleanflight, betaflight und inav flashen kann. Inav ist ein ableger von Cleanflight. daher meine bisherigen rückschlüsse.

    Attachments:
    You must be logged in to view attached files.
    #3326
    Avatar
    doing
    Teilnehmer

    Ich habe jetzt nochmal etwas damit herumgespielt und versucht Zusammenhänge zu erkennen.

    Der Copter steht auf dem Tisch. Starte ich die Motoren (Regler in der App auf die Mitte) dann Zeigt mir INAV Kurzfristig alle Motoren bei ~1500 an. Lasse ich die jetzt eine Weile laufen, dann nimmt der Wert für die vorderen Motoren langsam ab, der für die hinteren Motoren steigt hingegen langsam an?!

    Warte ich ne Weile, dann bleiben die vorderen Motoren irgendwann stehen, was ja nicht Sinn der Sache sein kann. Nehme ich den Copter in die Hand und schwenke ihn etwas um seine Achsen, dann kann ich beobachten, dass auch die stehengebliebenen Motoren wieder anfangen zu laufen. Während die hinteren Motoren je nach Bewegung des Copters auch mal auf 2000 hoch fahren erreichen die vorderen Motoren den Wert von 2000 nicht.

    Das kommt mir irgendwie spanisch vor… gehört das so?

    Kann man / muss man die Motoren individuell anpassen?

    #3327
    Avatar
    Uwe-RE
    Teilnehmer

    Hi,
    dieses Verhalten wird von der „Regelung“ verursacht. Winzige Abweichungen der Lage werden versucht auszugleichen und wenn der Kopter auf dem Tisch steht und ohne Luftschrauben läuft kann das nicht funktionieren. Die Regelung ist für den Flug gemacht und kann im stationären Betrieb nicht richtig arbeiten. Versuch mal einfach abzuheben das wird schon funktionieren.

    Gruß,
    Uwe

    #3328
    Avatar
    luckybenni
    Moderator

    Moin,
    für die WLAN Chipsatz Problematik hat MrEngman im RaspberryPi Forum ein Skript erstellt, mit welchem man die WLAN Treiber diverser RTL8x Chipsätze automatisch nachladen kann (https://www.raspberrypi.org/forums/viewtopic.php?t=6256).
    Diese Treiber funktionieren nach seinen Angaben z.T. besser, als die (neuen) Standardtreiber in Raspbian „Jessie“. Es scheint aber manche Chipsätze zu geben, die trotz funktionierender WLAN Funktionalität den Access Point Modus nicht sauber unterstützen – da hilft dann selbst dieser Treiber nicht weiter.
    Ich habe mir ebenfalls den Edimax EW-7811Un V2 gekauft, aber noch nicht zum Laufen bekommen – wahrscheinlich aufgrund „sudo apt-get update“ das Image zerschossen.
    Sobald ich mal wieder Zeit habe, versuch ich das Treiberskript auf dem frischen WiFree Image und schaue, wie weit ich komme.
    Grüssle, Benni

    #3330
    EagleEi
    EagleEi
    Keymaster

    Hallo Zusammen,
    wow hier ist ja richtig Schwung drin, das freut uns! 🙂

    Als erstes möchte ich kurz auf das Thema EINSTELLUNGEN INAV/CLEANFLIGHT eingehen.
    Wichtig ist, dass Ihr eurem Flightcontroler die Einbaulage mitteilt, die ESCs kaliebriert, die Motoranordnung richtig verkabelt und zum schluss eure Sensoren kalibriert!
    Hier habe ich den ersten Beitrag erweitert!

    Sebastian, ich bin mir sicher mit den beschriebenen Grundeinstellungen steht deinem erstflug nichts mehr im Wege!
    Wichtig für den Erstflug:
    1. möglichst genug Platz und weicher Untergrund (enge Wohnung mit viel Pflanzen könnte ärger geben… ich spreche von Erfahrungen! ;-))
    2. Der Copter benötigt mind. ca. 50cm höhe, damit er überhaubt fliegen und sein Controller sinnvoll regeln kann, am besten beim starten gleich mit ca. 50% Gas einsteigen.
    langsames beschleunigen verhindert eine brauchbare Regelung und dein Copter wird sich nicht richtig starten lassen!
    3. immer ca. mit 3-5m Abstand zum Copter starten, u solltest am Anfang immer hinter Ihm stehen, damit die Orientierung für den Anfang einfacher ist.

    Viel Erfolg und viel SPAß!!!!

    Benni, vielen Dank für deine Infos, diese werden wir morgen Abend bei unserem nächsten Projekttreffen anschauen!
    Was macht euer FABLab, ich hoffe da sind noch weitere WiFree Freunde im werden!? 😉

    schönen Abend zusammen!!

Ansicht von 15 Beiträgen - 16 bis 30 (von insgesamt 166)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.