WiFree Flightcontroller und die Firmware

Open DIY Projects Stuhlkreis WiFree Copter WiFree Flightcontroller und die Firmware

  • Dieses Thema hat 229 Antworten und 43 Teilnehmer, und wurde zuletzt aktualisiert vor 4 Monaten von AvatarAndi252.
Ansicht von 5 Beiträgen - 226 bis 230 (von insgesamt 230)
  • Autor
    Beiträge
  • #4943
    kiamalexkiamalex
    Teilnehmer

    Hallo Jürgen,
    habe mir dein Backup angesehen. Hab keinen entscheidenen Punkt gefunden, der helfen konnte. Trotzdem nochmal danke dafür.

    Habe jetzt aber eine Lösung gefunden!
    Mein NAZE32 hat noch eine F1-Prozessor. Habe ich zwar erst vor 1,5 Jahren gekauft, aber damit schon völlig veraltet:) Dieser scheint keine Hardware für die Invertierung des SBUS-Eingang zu besitzten. über den Parameter „sbus_inversion“ kann man sonst im INAV (nicht über das Menü sondern manuell über CLI) das Eingangssignal invertieren. Ich habe also einfach mit einer kleinen Schaltung das Signal invertiert und schon läuft jetzt alles!

    Die Einstellungen im INAV waren also alle schon richtig.

    Grüße
    Andreas

    #4944
    AvatarGashirn
    Teilnehmer

    Hi Andreas,

    freut mich, dass es jetzt funktioniert. Mein NAZE ist brandneu, scheinbar gibt’s da Unterschiede. Ich hab die Flightmodes noch hinzugefügt und damit heute trotz ziemlich heftigen Wind zwei Akkus leergeflogen. Die Datei häng ich nochmal dran. Damit ist der dreifache SWC für die Modes. Schalter nach oben ist Acro, Mittelstellung ist Angle und nach unten ist Horizon. Fliegt sich echt gut das Teil. Als nächstes rüste ich den TX auf Akku um; die Batterien nerven 😉

    Gruß
    Jürgen

    Attachments:
    You must be logged in to view attached files.
    #5123
    AvatarLuca11Black03
    Teilnehmer

    Hallo zusammen,
    mein Kumpel und ich haben alle Bauteile hier und zusammengebaut, nun sitzen wir am Flightcontroller und verzweifeln. Wir haben Betaflight,Cleanflight und Inav alle samt heruntergeladen und versucht zu connecten, jedoch scheitert es immer wieder. Mit Betaflight hatten wir manchmal Glück und kamen in die Konfiguration konnten dann auch die von uns gewünschten Änderungen vornehmen aber das saven und rebooten scheitert jedes mal. Wir haben auch schon in der Motorsektion versucht die Motoren zu testen aber keiner von ihnen reagiert oder zeigt jegliche Anzeichen von Bewegung. Haben den FC via USB-Port an den PC angeschlossen. Der Flightcontroller heißt F3 Flugcontroller Acro 6 DOF, die Motorregler sind die Little Bee 20 A und die Motoren sind die DYS 1806 2300kv 2-3s Black Edition.
    Der Raspi läuft und überträgt zuverlässig das Bild der Kamera an die App. Die Motoren sind über die Motorregler an die Batterie angeschlossen und via den weißen Kabeln, also die „Reglungskabel“ mit dem FC an den Pins 1-4 verbunden und sind in den Einstellung nach QuadX aufgebaut.
    Habt ihr eine Lösung wie wir das lösen können, dass wir eine Verbindung zwischen dem FC und den Motoren aufbauen können
    Danke im Voraus
    Luca

    #5164
    Avatarmotorengk
    Teilnehmer

    Hallo
    Ich bin offenbar zu spät auf diesen Zug aufgestiegen. Alles Material für den Bau eines WiFree-Copter’s liegt bereit. Der Raspi-Zero funktioniert, die App ist installiert, sogar Bilder von der Kamera werden auf’s Handy übertragen. Was ich aber nicht mehr hinkriege ist die Configuration des CC3D. Davon habe ich zwei Stück, eines mit einer hellen Platine und eines mit einer dunklen Platine. Die Software INAV-Configurator und die Software Clean-Flight unterstützen den CC3D nicht mehr. Daher meine Frage. Finde ich hier jemanden der mir eine vielleicht eher zahme Version einer Konfiguration auf mein Bord Flasht? Das Flashen allerdings geht noch mit der neuen INAV Version 2.3.3. Notfalls würde eine funktionierende HEX-Datei auch reichen. Mein Standort ist in der Schweiz, erreichen kann man mich über hb9fek@bluewin.ch Für eine Antwort bin ich dankbar.
    Gerhard

    #5165
    AvatarAndi252
    Teilnehmer

    Hallo Gerhard,

    probier mal das angehängte HEX-File, 1.7.3 ist die letzte INAV-Version für den CC3D und das HEX ist mit USE_RX_MSP compiliert, da dieses Format normalerweise nicht aktiviert ist. IBUS ist deaktiviert.

    Gruß,

    Andreas

Ansicht von 5 Beiträgen - 226 bis 230 (von insgesamt 230)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.