Bauberichte EagleEi Gimbal 3axis

Open DIY Projects Stuhlkreis EagleEi Gimbal 3axis Bauberichte EagleEi Gimbal 3axis

Dieses Thema enthält 42 Antworten und 7 Teilnehmer. Es wurde zuletzt aktualisiert von EagleEi EagleEi vor 2 Jahre, 11 Monate.

Ansicht von 15 Beiträgen - 1 bis 15 (von insgesamt 43)
  • Autor
    Beiträge
  • #705
    miata
    miata
    Moderator

    Hallo zusammen,

    Ich bin schon fleißig am bauen und möchte mal über mein eigenes Bauvorgehen berichten. Vorweg, ich denke ein versierter Modellbauer zu sein, nur mit der neuen Elektronik bin ich nicht so sehr vertraut…GUI, IMU.. Hä? Aber man kann sich ja belesen… Also keine Angst wenns euch je auch so geht :-))

    1. Der Holzbausatz…
    …war relativ einfach aufzubauen. Natürlich muß man die Bilder öfters und genauer studieren, zb wo welcher Zapfen hin muß, wierum welches Brettchen sein muß, usw.. aber sicherlich kein Hexenwerk.
    Geklebt habe ich alles mit Sekundenkleber, weil ich den da hatte.
    An den Motoren die Achsen mitm Drehmel abgeflext. Am besten die Achse durch ne Folie stoßen und den Motor damit schützen, damit der Metallstaub nicht in die Motoren/Magnete kommt. Auch die Motoren klebte ich punktuell mit Sekundenkleber ein. Das saubere ausrichten der Kamerawippe, damit diese auch mit der Messinghülse gut läuft, war doch etwas knifflig. Aber klappte dann ganz gut.
    Am Ende das Holzgestell schön anschleifen, aber das nur der Optik wegen.

    2. Die Verkabelung…
    da war ich lange unentschlossen mir die Mühe zu machen komplett alles auf Litze umzulöten. Noch dazu schienen mir die original Motoren-/Sensorkabel sehr gut flexibel. Auch die Länge aller Kabel scheint doch grade noch so zu reichen.
    Daher wage ichs mal, und verwende alle Kabel so wie sie sind. Natürlich etwas direkter/simpler/freier verlegt. Ich bin gespannt obs auch so funktioniert. Im schlimmsten Falle bau ich die Verkabelung eben anders.

    Also zusammenfassend 3Motorenkabel, 1 Sensorkabel verlegen zur Platine.
    Motorenkabel anlöten: Mot1=raufrunter, Mot2=kippen, Mot3= Horizontschwenken.
    Sensorkabel konnte belassen werden und wird ja nur gesteckt. Logischerweise mußte ein Steckergehäuse kurz abgenommen werden um das Kabel durch die Schwenkhülse zu stecken.
    Steckerleisten noch anlöten um später die Platine mit…“Dingsda und PC“ verbinden zu können.
    Zusätzlich habe ich für mich mir einen Schutz gegen Kurzschluß(Absturz) und Verpolung in die Zuleitung gebastelt. Einen Sicherungshalter (20mm Glassicherung), an den ich noch eine Diode angelötet habe. Dürfte funktionieren.

    So, der Rohbau steht. Demnächst geht’s ans programmieren… uuuaaahhh :-). Ich werde dann wieder berichten.

    Grüße
    Micha

    #708
    Flieger-Dt
    Flieger-Dt
    Teilnehmer

    vielen Dank für die prima Anleitung!

    Ich habe heute das Material bekommen und Ich wollte noch ein paar Worte zu meinem ‘Projekt’ sagen: Das EagleEi Gimbal soll u.a. beim ‘Einleiner-Drrachenfliegen’ eingesetzt werden, um Luftbild-Videos aufzunehmen.

    Ich habe heute Nachmittag begonnen, die gelaserten Teile (ohne die Aufbauanleitung, mangels I-Net …) zusammen zu puzzlen und war nach ca. 90 Min. soweit fertig damit, dass ich die Teile zum verleimen zusammengestellt habe 😉

    Falls es hierhin passt, kann ich weitere Baufortschritte hier einstellen.

    Gruß in die Runde und Danke für dieses schöne Projekt,
    Klaus

    Dateianhänge:
    You must be logged in to view attached files.
    #713
    Flieger-Dt
    Flieger-Dt
    Teilnehmer

    und noch ein Nachtrag:

    Auf meine Fragen zum Bau (wie kann ich am Besten die Motorwelle kürzen, sollte ich die Motoren dabei abkleben, wg. evtl. Metallspänen / muß ich die Motoren mit dem Gimbal verkleben),
    habe ich von den ‚Machern‘ schnelle und kompetente Antworten erhalten, die ich hier zitieren darf:

    „Die Motoren:
    – du kannst mit zwei Finger den Anker von der Glocke ziehen, (keine Angst) die hält lediglich mit der Magnetkraft, das ist super!
    – am besten die Glocke mit einem Klebeband abkleben und Achse absägen.
    Alternativ: Ich habe die immer mit dem Drehmel abgeschliffen, ging schneller und ich hab mir das abkleben gespart! 😉

    Bei mir habe ich bislang keinen Motor zwingend verkleben müssen, da meist die „Presspassung“ ausreicht. Habe aber gesehen, dass je nach Toleranz beim lasern und der Luftfeuchtigkeit auch mal der Motor etwas loser sind ein Tropfen Leim/Sekundenkleber hält besser.“

    #737
    EagleEi
    EagleEi
    Keymaster

    Hallo Micha,
    ich hab unser Thema in Grundeinstellungen verschoben, dort können wir uns mit den Installationsthemen auseinander setzen und hier übersichtlich die Bauberichte aufführen.
    moved to: https://open-diy-projects.com/topic/storm32-bgc-die-perfekten-grundeinstellungen/

    #750
    Flieger-Dt
    Flieger-Dt
    Teilnehmer

    Hi –
    meine ‚Baustelle‘ zeigt auch Fortschritte: Das ‚Holzständerwerk‘ steht 😉
    Im Nachhinein ‚bereue‘ ich, dass ich Expressleim genommen habe, da bleibt kaum Zeit zu korrigieren …
    Die perfekte Passgenauigkeit leidet ein wenig, das Ergebnis sieht aber ganz gut aus. Die Motoren habe ich z.T. versucht, mit Heisskleber zu fixieren, da muß ich noch nacharbeiten.
    Was mir auffällt, meine Mobius ist in der ‚Rollachse‘ mächtig aus der Waage (?) …
    Ich versuche, kleine Bohrungen mit Bleikügelchen zu füllen. Keine Ahnung, wie die ‚Schieflage‘ entstanden ist.
    Bei mir geht’s frühestens am SO weiter, dann gibt’s auch Dasein oder andere Foto

    #751
    EagleEi
    EagleEi
    Keymaster

    Hallo Flieger-DT,
    schön dass du so gut voran kommst.
    Leim würde ich generell auch vorziehen, da hast einfach noch ein paar Sekunden Zeit etwas aus zu richten.

    Warum die Mobius bei dir aus der Mitte ist, keine Ahnung!
    Bei mir und auch während der Konstruktion habe ich darauf geachtet dass die Mobius balanciert ist.
    Es könnte allerdings sein, dass der Akku in der Mobius nicht immer gleich sitzt und je nach den Schwerpunkt verschiebt!?
    Hier könnte auch eine Lösung für dich sein, den Akku in der Mobius etwas in die gewünschte Richtung zu verschieben!?

    #753
    Flieger-Dt
    Flieger-Dt
    Teilnehmer

    Hmm –
    auf die Schnelle noch einmal …
    Ich habe einen größeren Akku nachgerüstet, aber der sitzt passend. Da er größer und schwerer ist, müßte die Mobius eher noch besser ausbalanciert sein.
    Ich habe fix zwei CR2032 Knopfzellen mit Klebeband auf der ‚leichteren Seite‘ befestigt, ist schon besser. Scheint also nicht viel zu sein …
    Ich werde es mit den Bleikügelchen versuchen, muß aber auch noch irgendwie die Mobius ‚fixieren‘ denn fest ist sie nicht in der Halterung …

    #754
    EagleEi
    EagleEi
    Keymaster

    Für die Befestigung der Mobius nehme ich immer doppelseitiges Klebeband, so ein Spiegeltape ohne Schaum. Die Mobius kannst damit ca. 5x Fest machen danach braucht man einen neuen Streifen mit ca. 2x2cm.

    Zum Schwerpunkt, vermutlich hast du dann noch eine andere Linse, als ich!?
    Falls du deinen USB-Port nicht nutzen möchtest, so kannst du natürlich auch die USB-Halterung abtrennen und die Cam beliebig ausrichten.

    #755
    EagleEi
    EagleEi
    Keymaster

    Nebenbei, wenn der Schwerpunkt für die Cam nicht 100% richtig stimmt, ist das nicht zwingend schlimm. Die Rollachse ist Zb. auch nicht im Schwerpunkt, da die Motoren mit 20g leider um ca.10g zu schwer sind.
    Ich vermute mal dass der Schwerpunkt bei größeren Cams die um ein vielfaches schwerer sind als die Motoren dies wichtiger ist, jedoch bei der 39g Mobius ist das vermutlich nicht so Wild.
    Ich habe mal Versuche gemacht mit Gegengenewicht und ohne, konnte bei der Funktion keine Unterschiede feststellen. Lediglich beim initialisieren sollte die Cam halbwegs gerade stehen, sonnst kann es vorkommen dass die Cam nicht richtig anläuft.

    #756
    Flieger-Dt
    Flieger-Dt
    Teilnehmer

    O.K.,
    das würde ziemlich genau passen, denn ich müßte die Rollachse mit ca. 10gr ausbalancieren, hab‘ ich gerade ausgewogen.
    Vielleicht wäre es ein ‚Verbesserungsvorschlag‘, wenn die Kamerahalterung etwa 3mm oder mehr breiter wäre, könnte man die ‚Klickhalterung‘ der Mobius einkleben, bzw. die Rollachse ausbalancieren.
    Ich habe auch noch ein, zwei weitere Vorschläge (Befestigung/Sicherung der Motoren) …
    Mit Fotos klappt es aber frühestens SO erst wieder (heute Abend ‚kein Licht‘ und morgen bin ich den ganzen Tag unterwegs.

    #757
    EagleEi
    EagleEi
    Keymaster

    Verbesserungsvorschläge sind immer gern Willkommen, das ist das Ziel auf Open-diy-projects ! 🙂

    #820
    Flieger-Dt
    Flieger-Dt
    Teilnehmer

    Hi –

    bei mir gibt’s Fortschritte:
    Am meisten freut mich, dass nach der ‚Grundkonfiguration‘ und Übernahme der PID Werte aus den Tips zu ‚Grundeinstellungen + GUI‘ die Mobius Aufhängung wie gewünscht funktioniert!

    Ich habe die Pitch- und Rollmotoren mit RC-Steckern verlötet und mit dem Board verbunden, den YAW-Motor bzw. die Anschlusslitzen direkt auf dem Controller verlötet.

    Dann habe ich die IMU auf dem Controller einer 1-Punkt- und die Kamera-IMU einer ‚6-Punkt-Kalibrierung‘ unterzogen.
    Die Anschlusskabel passen bei mir leider nicht durch die Messingachse. Insgesamt muß ich mir noch Gedanken um die ‚Verkabelung‘ machen.

    Rückgängig gemacht habe ich die Verklebung des ‚Rollachsenmotors‘ mit Heisskleber (keine gute Idee von mir …). Da ist jetzt die Verbindung etwas ‚wackelig‘, ich habe schon eine Idee zur Fixierung, wenn’s klappt, zeige ich’s.

    Die ‚Befestigung‘, bzw. eine Ausblanciermöglichkeit der Mobius ist für mich noch nicht so ganz zufriedenstellend.

    Jetzt muß ich noch einmal schauen, wie ich den Pitchmotor per Fernsteuerung verstellen kann …

    #823
    EagleEi
    EagleEi
    Keymaster

    Hallo Klaus,
    das hört sich toll an! … Heisskleber ist bei Holz nicht so toll.
    Ich habe an der Stelle gute Erfahrungen mit dickflüssigen Sekundenkleber gemacht.
    Aber auch 2K Harz sollte auch gehen.

    Schön, dass die Grundeinstellung schon Plug&Play läuft!
    Falls es Jemand etwas bringen sollte, im Bereich „Firmware, Grundeinstellungen…“
    könnt Ihr mein Setup als Grundlage als EagleEi 3AxisV1.0.cfg Datei runterladen.

    #830
    miata
    miata
    Moderator

    MEINS TUUUUUUTTT!
    ————————————————————————
    Kurz was ich baulich anders gemacht habe:
    Habe alle Kabel so verwendet wie sie dabei waren. Also es geht auch ohne umlöten auf Litze.
    Die Motorenkabel sind sehr flexibel, ebenso das der IMU. Wenn man die Motorenkabel NICHT zusammen macht sind sie leichter beweglich. Sieht nicht ganz so gut aus, funktioniert aber sehr gut so.

    Das ist noch der Rohbau wie man auf dem Bild sieht, aber es tut. Jetzt wirds noch etwas schön und im Detail vollends richtig aufgebaut, dann gehts in die Luft.

    Ich bin gespannt. Allen Nachbauern viel Spaß und gutes Gelingen.

    Grüße
    Micha

    Dateianhänge:
    You must be logged in to view attached files.
    #884
    Flieger-Dt
    Flieger-Dt
    Teilnehmer

    Hi –

    ich wünsche euch allen noch ein schönes OsterEierFest 😉

    Ich habe noch einen Nachtrag: Nachdem ich das Control Board zum ersten Mal ‚verkabelt‘ hatte, habe ich versucht, die Bluetoothschnittstelle zu konfigurieren. Danach konnte ich unter WIN XP eine Bluetooth-Verbindung herstellen, fand aber keine ‚Dienste‘ – die Verbindung habe ich dann auf dem Laptop nicht zurück gesetzt und habe versucht, einen anderen Treiber auf dem Laptop zu installieren.

    Seit dem war es nicht mehr möglich, mit Hilfe des ‚Bluetooth Module Configure Tool‘ die Schnittstelle zu konfigurieren, bekam aber nur noch Fehlermeldungen, kein BT Modul vorhanden, per manueller ‚Kommunikation‘ mit dem Modul über @AT ‚antwortet‘ das Board nur noch mit der Ausgabe ‚eee‘.

    Da ich auf ein defektes BT Modul getippt habe und ich auf Anfragen beim Händler keine Antwort erhielt, habe ich ein neues BT Modul HC06 bestellt.

    Beim auslöten ist mir dann ein blöder Fehler unterlaufen und ich habe auf der Platine zwei Anschlüsse ‚abgerissen‘.
    Der Controller funktionierte immer noch ohne Probleme!

    Heute Abend habe ich dann ein neues HC06 Modul per ‚Verkabelung‘ mit den RX und TX, sowie GRD und 3,3V Anschlüssen verbunden. Weiterhin keine automatische Konfiguration möglich und weiterhin ‚meldet‘ sich das Board mit ‚eee …‘ ;-((
    Hat jemand noch eine Idee, ob ich die BT-Schnittstelle ’neu konfigurieren‘ kann?

    Gruß, Klaus

    Dateianhänge:
    You must be logged in to view attached files.
Ansicht von 15 Beiträgen - 1 bis 15 (von insgesamt 43)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.