Antwort auf: WiFree Flightcontroller und die Firmware

Open DIY Projects Stuhlkreis WiFree Copter WiFree Flightcontroller und die Firmware Antwort auf: WiFree Flightcontroller und die Firmware

#4015

hama0013
Teilnehmer

Ja, so schön wie das Projekt anfangs ausgesehen hatte – das Flashen des CC3D ist ziemlich instabil. Ich denke, wenn das jemand im Griff hat, gilt das dann nur für dieses eine Board mit diesem einen Boot-Loader, dieser einen INAV Konfiguratorumgebung und einer ganz bestimmten Abfolge. Ich hatte meinen CC3D nach vielen Versuchen soweit, dass ich problemlos die Firmware draufspielen(über INAV 1.5.2) und auch Parameter ändern konnte.
Abfolge war folgende:
Erst mal CC3D über USB (ohne Brücke) anschließen. Dann in der Software den passenden COM-Anschluß anwählen. In Normalfall hatte die Software hier das Board noch nicht erkannt. Nun Software beenden, USB abziehen und wieder aufstecken und neu INAV neu starten. Dann wurde das Board erkannt. Jetzt wieder Software beenden und Board vom Rechner(USB) nehmen, RS232-Wandler ans Board anschließen, Brücke setzen, Externe Spg. Versorgung an den USB und RS232-Wandler an PC anschließen und INAV starten. Nun muss noch der neue COM-Port für den RS232-Wandler eingestellt werden. Dann wurde das Board von der Software für FW-Update gefunden. Aber auch das musste ich ggf. mehrmals wiederholen bis es klappt.
Problem bei mir waren die anderen Werte der PID Einstellungen. Wie im Post weiter oben beschrieben passt das alles nicht mit den Projekt-Vorgaben zusammen. Aber ich bin auch immer noch bei den „Trockenübungen“ da immer noch ein Motor fehlt.

Ich habe inzwischen über Bekannte den Hinweis zur „besseren“ Controller-SW „LibrePilot“ erhalten:
https://librepilot.atlassian.net/wiki/display/LPDOC/Welcome
Da funktioniert der FW-Update alleine über die USB-Schnittstelle des Boards. Habe das auch inzwischen am Board am Laufen – war aber auch ganz schön kniffelig. Beschreibung hier:
http://www.southquay3d.com/index.php?route=news/article&news_id=9
Hat jemand den Wifree-Copter mit LibrePilot funktionsfähig am Laufen, oder kann jemand was zum Vergleich „LibrePilot“<>“INAV“ sagen?

Allerdings schaffe ich es jetzt überhaupt nicht mehr das INAV zum Laufen zu bringen – nicht mal mehr zum FW-Update… Aber momentan ist bei mir auch der RS232-Wandler kaputt – muss da erst mal einen neuen beschaffen..scheinbar haben dem die vielen An-Absteckvorgänge nicht so gut bekommen. Bin da momentan auch ein wenig gefrustet…

Ich denke, ein aktualisierte Beschreibung zur Inbetriebnahme mit aktuell verfügbaren Softwaren wäre sehr hilfreich für alle, die das Projekt in Angriff nehmen. Ich wäre jedenfalls sehr dankbar dafür!

Gruß,
Mathias